<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Dave Peterson wrote:
<blockquote cite="mid:48C03CBE.4070301@enthought.com" type="cite">
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
I was under the impression that Windows users could use the MinGW
compiler to build things compatible with the MSVC we used to build
EPD.&nbsp;&nbsp; That's one of the reasons we ship it.<br>
  <br>
</blockquote>
You are almost certainly correct - I did not have time to deal with
this in detail and found that VS03 worked well enough.&nbsp; MinGW would be
better.<br>
<blockquote cite="mid:48C03CBE.4070301@enthought.com" type="cite">I
don't know anything about DeinoMPI, but it seems to be the MPI libs
that mpi4py will link against, right?&nbsp; If so, you should be able to
build mpi4py against a MSVC version of these by making sure to set your
distutils.cfg or pydistutils.cfg to define the compiler to use to be
mingw.&nbsp;&nbsp; There are numerous threads on doing this on various mailing
lists, plus it is covered in the distutils docs.<br>
</blockquote>
Hm - you are probably right - DeinoMPI is the culprit, not EPD.&nbsp; The
build error was from mpi4py of course.&nbsp; I will look into the cfgs.<br>
<blockquote cite="mid:48C03CBE.4070301@enthought.com" type="cite">BTW,
in the future, an EPD install will contain an appropriately setup
distutils.cfg to default the compiler to the mingw we ship in EPD.&nbsp;&nbsp;
IIRC, it is already in the current beta -- EPD with Py2.5 v4.0.30001
Beta 1.<br>
  <br>
  <br>
-- Dave<br>
  <br>
</blockquote>
Great - thanks again.&nbsp; I'm not inexperienced with software make/build
tools in other contexts but Python internals and distribution tools are
still somewhat new to me;&nbsp; I appreciate everyone's interest.<br>
<br>
- Alex<br>
<br>
</body>
</html>