Jörgen,<br>Great idea and it did the trick.&nbsp; I set the width of the window and the window buffer to be the same and now it looks like all works.&nbsp; <br><br>For completeness, I went to my &quot;working&quot; Windows 2000 machine and changed them so they are not same, this then causes the problem to appear.&nbsp; Changing that back fixes it.
<br><br>Thanks,<br>&nbsp;&nbsp; -jesus<br><br><br><div class="gmail_quote">On Dec 20, 2007 1:34 PM, Jörgen Stenarson &lt;<a href="mailto:jorgen.stenarson@bostream.nu">jorgen.stenarson@bostream.nu</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Jesus,<br><br>I&#39;m not sure what the problem could be, but I have one idea. Do you have<br>your console window settings such that both the window and the window<br>buffer has the same width. It could be that you have aa wider buffer and
<br>the completions are formatted to suit the buffer width and not the<br>window width.<br><br>For future debugging could you perhaps email me screenshots of the<br>windows showing the problem. That might give me more ideas as well.
<br><br>/Jörgen<br><br><br>Jesus Aguillon skrev:<br><div class="Ih2E3d">&gt; Update:<br>&gt; I installed a fresh copy of pyreadline 1.5 and IPython 0.8.2 on a<br>&gt; Windows 2000 machine and I don&#39;t see the problem.<br>
&gt;<br>&gt; I then went to my Windows XP2 machine and uninstalled Ipython and<br>&gt; pyreadline and then reinstalled fresh copies and I DO see the problem.<br>&gt; So I&#39;m not sure if it is OS dependent or something else.
<br>&gt;<br>&gt; Thanks,<br>&gt;<br>&gt; On Dec 20, 2007 9:55 AM, Jesus Aguillon &lt;<a href="mailto:jesus@aguillon.com">jesus@aguillon.com</a><br></div><div class="Ih2E3d">&gt; &lt;mailto:<a href="mailto:jesus@aguillon.com">
jesus@aguillon.com</a>&gt;&gt; wrote:<br>&gt;<br>&gt;<br>&gt;<br>&gt; &nbsp; &nbsp; On Dec 20, 2007 12:44 AM, Fernando Perez &lt;<a href="mailto:fperez.net@gmail.com">fperez.net@gmail.com</a><br></div><div class="Ih2E3d">&gt; &nbsp; &nbsp; &lt;mailto:
<a href="mailto:fperez.net@gmail.com">fperez.net@gmail.com</a>&gt;&gt; wrote:<br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; On Dec 18, 2007 11:42 AM, Jesus Aguillon &lt;<a href="mailto:jesus@aguillon.com">jesus@aguillon.com</a><br></div><div><div>
</div><div class="Wj3C7c">&gt; &nbsp; &nbsp; &nbsp; &nbsp; &lt;mailto:<a href="mailto:jesus@aguillon.com">jesus@aguillon.com</a>&gt;&gt; wrote:<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; When I do tab completion, it looks like in 0.8.1 everything<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; is laid out in 3
<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; nice columns, whereas in 0.8.2 everything seems to scroll off<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; to the right.<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; In 0.8.1 everything is laid out in 3 columns &nbsp;and multiple<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; rows whereas in
<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; 0.8.2 I will sometimes get one very long row, or 4 very long<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; rows and a<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; bunch of columns.<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; For example:<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; import os
<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; os.&lt;TAB&gt; &nbsp;gives me 3 columns in 0.8.1 and many rows<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; os.&lt;TAB&gt; gives me many columns and 4 rows (so I have to<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; scroll off to the<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; right).<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; Is there a configuration parameter that controls how this<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; works? &nbsp;I am on<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&gt; Windows XP2 and I upgraded from 
0.8.1 to 0.8.2.<br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; I&#39;m afraid the problem isn&#39;t visible under &nbsp;linux, but perhaps<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; Jorgen<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; will be able to suggest something. &nbsp;In the meantime, I suspect it<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; would be useful for him if you can provide the version of pyreadline
<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; you&#39;re using in both cases. &nbsp;If you are NOT using the latest (1.5),<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; please upgrade from<br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://ipython.scipy.org/dist/pyreadline-1.5.win32.exe" target="_blank">
http://ipython.scipy.org/dist/pyreadline-1.5.win32.exe</a><br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; and let us know if the problem persists.<br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; Cheers,<br>&gt;<br>&gt; &nbsp; &nbsp; &nbsp; &nbsp; f<br>&gt;<br>&gt;<br>&gt; &nbsp; &nbsp; Hi Fernando,
<br>&gt; &nbsp; &nbsp; Sorry about the oversight, I am using pyreadline 1.5.<br>&gt; &nbsp; &nbsp; thanks,<br>&gt;<br>&gt;<br>&gt;<br>&gt;<br>&gt;<br>&gt; --<br>&gt; Jesus Aguillon<br>&gt; Voice: (408) 786-5876<br>&gt; Skype: jaguillo56<br>&gt;
<br>&gt;<br></div></div>&gt; ------------------------------------------------------------------------<br>&gt;<br>&gt; _______________________________________________<br>&gt; IPython-user mailing list<br>&gt; <a href="mailto:IPython-user@scipy.org">
IPython-user@scipy.org</a><br>&gt; <a href="http://lists.ipython.scipy.org/mailman/listinfo/ipython-user" target="_blank">http://lists.ipython.scipy.org/mailman/listinfo/ipython-user</a><br><br></blockquote></div><br><br clear="all">
<br>-- <br>Jesus Aguillon<br>Voice: (408) 786-5876<br>Skype: jaguillo56<br>