Hi,<div><br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="Ih2E3d">&gt; it seems to me that cursor movements with ^a, ^e etc. are broken on
<br>&gt; Leopard. It seems to work, yet the display is not updated<br>&gt; appropriately. This problem is consistent in Terminal.app, iTerm and<br>&gt; xterm so I guess it&#39;s not a terminal emulator bug.<br><br></div>I can&#39;t duplicate this behavior in 
Terminal.app or xterm (don&#39;t have<br>iTerm lying around anymore).</blockquote><div><br class="webkit-block-placeholder"></div><div>Strange. I did a fresh install of the OS and currently fail to see what could be wrong...
</div><div>&nbsp;</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">I tested it on the Leopard Python w/ the recent readline fix installed<br>(although I think I remember it being fine previously as well).
</blockquote><div><br class="webkit-block-placeholder"></div><div>What do you mean with &quot;recent readline fix <span class="Apple-style-span" style="font-style: italic;">installed</span>&quot;? I thought it was a mere</div>
<div><br class="webkit-block-placeholder"></div><div><span class="Apple-style-span" style="font-family: Verdana; font-size: 12px; ">import readline<br>readline.parse_and_bind ("bind ^I rl_complete")</span><br class="webkit-block-placeholder">
</div><div><br class="webkit-block-placeholder"></div><div>at the prompt?</div><div>&nbsp;</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Is this just happening in IPython for you, or is it in any terminal in&nbsp;general?
</blockquote><div><br class="webkit-block-placeholder"></div><div>Only ipython seems to be affected as far as I can tell. The stock python prompt works as expected. I found another symptom of the problem, though: When I use the up key to get to the history, the history is sometimes appended to the current line. This does not affect the actual action called when I hit enter on this line of the history. So it all seems to be a problem in the display code...
</div><div><br class="webkit-block-placeholder"></div><div>Thanks again,</div><div><br class="webkit-block-placeholder"></div><div>Markus</div></div></div>